
PLUS TWO HUMANITIES-COMPUTER APPLICATION

UNIT -2

Introduction to Word Processors

I)  Word  Processor  : is  an  application  software  tool  that  processes  textual
matters and creates flawless documents. Eg: LibreOffice Writer,  Microsft Word
,PageMaker, AbiWord.

II)Document is a file that contains text or images. Eg : biodata,reports,letters….

III) Features of a Word Processor

a) Quickness : Documents can be created ,edited ,saved and printed quickly
and easily.

b) Word wrapping: It is the feature of  automatic  placing of the word that
passes the right margin to the next line.

c) Editing Features:  It  is  the  process  of  correction  like  deleting,  moving
,inserting…..of text or graphics.

d)  Tables:     They help to present text in rows and columns.

e) Formatting features: Formatting is the process of making the documents
more legible and attractive.

f) Header ,Footer and Page Number:
Header: Text appears at the top of all pages of a document.
Footer : Text appears at the bottom of all pages. 
Page Number: Continuous numbers given to each page in a document .

g) Object Linking and Embedding (OLE): It is the technology of sharing
information between programs through objects.  The objects  like  images
,charts ..created with other softwares can be linked and embedded with the
document.

h) Spell  Check and Grammar Check:  Word Processor  keeps  a  standard
built  in dictionary.  Using it  the word processor scans the document and
checks for the spelling and grammar mistakes. 

i) Mail Merging: It is facility of printing many copies of the same content
with different addresses.

j) Index and Table of contents: Index is the collection of important words
in  the  document.  Table  of  contents includes  main  headings  and  sub
headings .It is placed at the beginning of the document.
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k) Templates:  are  the  predefined  document  formats.  It  helps  to  create
documents  easily by just entering text at the required positions.

IV) LibreOffice Writer IDE

Integrated Development Environment: It  provides facility to create ,
edit and print the document. The main components of IDE of LibreOffice Writer
are Title bar, Menu bar, Tool bars ,Ruler, Scroll bars,Status bar and Text area.

1. Title Bar
It  shows the  name of  the document,  name of  the software  and control

buttons.

2.Menu Bar
It displays  the available menu such as File,Edit ,Insert etc. Each menu may

contain pull down menus and sub menus.

3.Tool Bars
 Tools (buttons) are the icons (small pictures ) of the short cut commands.
When we place the mouse pointer over a button,  a short  text describing it  is
appeared. It is called Tool Tip.

There  are  many  tool  bars  like  standard  tool  bar,  Formatting  tool
bar,Drawing tool bar etc.

4.Scroll bars
Scrolling is the process of moving through up and down or left and right

through the document. It is done by by the vertical and horizontal scroll bars .

5.Ruler
The left and right ruler bars allow to set the margins of the document.

Margin is the distance between he text and an edge of the paper.

Four types of margins

1. Left margin: Distance between the text and the left edge of the paper.
2. Right margin: Distance between the text and the right edge of the paper.
3. Top  margin: Distance between the text and the top edge of the paper.
4. Bottom margin: Distance between the text and the bottom edge of the paper.

6. Status bar
It can be seen at the bottom of IDE. It shows the page numbers,language

,number of words ,characters ,zoom area etc. Zoom area is useful to get closer
and distant view of the document.

7.Text area:
It is used for entering text in a document. It is also called the document

area.

V) Creating a New Document:

A new document can be created using any one of the following method:
1. command sequence : File > New
2. Short cut keys          : Ctrl+N
3. Tools                         :New button in the standard tool bar

Kunhabdulla PT. GGHSS Thalassery ,Phone :98 0 98 52 1 52                Page 2



In such cases a new document will be opened in the IDE window.

VI) Saving a Document:

A  document  can  be  saved  for  the  first  time  using  any  one  of  the  following
procedure:

1. command sequence : File > Save
2. Short cut keys          : Ctrl+S
3.Tools                          :Save button in the standard tool bar

The Save window will be appeared. Give suitable file name and click on the Save
button. The file will be saved with the file extension .odt.

Save As command is used to save the same document in a different name and
format:

For this any one of the given methods can be used:
1. command sequence : File > Save As
2. Short cut keys          : Ctrl+shift+S
3.Tools                          :Save  As button in the standard tool bar

VII) Closing a Document:

A document (without LibreOffice Writer Application) can be closed using any one
of the following method:

1. Command sequence : File >Close
2. Tools                :Close button at the right side of the menu bar.

If  we have not saved the document  Writer will  prompt us with a dialog
box .It contains Close ,Close without Saving ,Cancel and Save options.

Closing a Document and LibreOffice Writer Together

A document and the LibreOffice Writer application can be closed together using
any one of the given procedure:

1. command sequence : File > Exit LibreOffice
2. Short cut keys          : Ctrl+Q
3 Tools                          :Close button in the title bar

VIII) Opening a Document 

1.Command sequence : File > Open
2. Short cut keys          : Ctrl+O
3.Tools                          : Open button in the standard tool bar

Open dialog box will be appeared. Choose the file and click on the Open
button in the window.
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IX) Editing a Document 

  It  is  the  process  of  correction  like  deleting,  finding,
moving,replacing ,inserting…..of text or graphics.

A. Prerequisites for editing: 
We  need  to  perform  some  operations  like  navigation  ,Insert/OverWrite

mode setting ,undo/redo actions ,text selection etc for editing the document.

1.  Navigation :  It  is  the  process  moving  from  one  point   to  another   in  a
document. 
Navigation can be performed using : 

a)keyboard b) mouse and c)scroll bars

 a) keyboard

Arrow keys: To move cursor to the very next character or line of the document.
Home :To move to the beginning of the current line.
End     :To move to the end of the current line.
Page Up:To move to the page just before the current page.
Page Down:To move to the page just after the current page.

Ctrl+>: To move to the beginning of the next word.
Ctrl+< :To move to the beginning of the previous word.
Ctrl+Home : To move to the beginning of the document.
Ctrl+End : To move to the end of the document.

b)Mouse :
 By moving the mouse pointer we can place the cursor any where in the
document. The scroll button of the mouse helps us to navigate through the pages
of the document.

c)Scroll bars:
By dragging the scroll buttons in the scroll bars we can move  up,down,left

and right of the document.

2.Insert/Overwrite mode setting:
       The Written documents are set any one of the given two modes using Insert
key. It is a toggle type key. By default  the document is in insert mode. The mode
status of the document  is displayed in status bar.

Insert mode: A new character can be inserted without losing the existing one.

OverWrite Mode:  A new character can be inserted by deleting the existing one.

3.Undo and Redo actions

Undo : To cancel the most recent action.

1.command sequence : Edit > Undo
2.Tools                          :Undo button in the Standard tool bar
3. Short cut keys          : Ctrl+Z
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          Redo : To retrieve the most recent action canceled by Undo.

1.Command sequence : Edit > Redo
2.Tools                          :Redo button in the Standard tool bar
3. Short cut keys          : Ctrl+Y

4. Text Selection
It is the process of selecting a block of text prior to edit.

It can be done in two ways:

a. Using the Mouse

Place the cursor at beginning of the text, hold down the left button and
drag.

b. Using the Keyboard

Place  the  cursor  at  the  beginning  of  the  text,hold  down  shift  key  and  press
navigation keys.

To select the whole document

Command sequence: Edit>Select All
Short cut keys:  Ctrl+A

B. Cut,Copy and Paste functions

Cut- Moving text from one part of the document to  the other  part.
Copy- Makes the several copies of the text in different parts of the document.

Cut and Paste Functions

It requires the following steps:
1.select the text.
2. cut the text using any one of the following method.

a. Command sequence:Edit> Cut
b. Short cut keys         : Ctrl+X
c. Tools                        : Cut button in the standard tool bar
d .Mouse         : click right button and select Cut from context menu

3. Place the cursor in the position where text is to be moved.
4. Paste the text using any one of the following method.

a. Command sequence:Edit> Paste
b. Short cut keys          : Ctrl+V

c. Tool         :Paste button in the standard tool bar
d. Mouse     : click right button and select Paste from context menu.

Copy and Paste Functions

It requires the following steps:
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1.select the text.
2. copy the text using any one of the following method:

a. Command sequence: Edit> Copy
b. Short cut keys    : Ctrl+X
c. Tools                    : Copy button in the standard tool bar
d .Mouse      : click right button and select Copy  from context menu

3. Place the cursor on the position where text is to be moved.
4. Paste the text using any one of the following method:

a. Command sequence:Edit> Paste
b. Short cut keys    : Ctrl+V

c. Tools     :Paste button in the standard tool bar.
d .Mouse  : click right button and select Paste from context menu.

Comparison

Cut-Paste Copy-Paste

Does not duplicate text. Duplicates text.

Selected  text  will  be  present  at  the
destination only.

Selected text will be present both at the
source and destination.

Moves  the  text  from  one  place  to
another.

Copies  text  to  other  parts  of  the
document.

C. Deleting a Text

It is the process of removing a text permanently from the document.

Methods:

1. Cut the text using cutting options.
2.Press Del key- to delete text leads  the cursor.
3. Select the text and press Del key to remove the selected text.
4.Press Back space to delete the text preceds the cursor.

D.Find and Replace facility

a) Finding  a text

Locating a particular word in a document.
It is done by using any one of the following method:

1.command sequence : Edit >Find

2. Short cut keys          : Ctrl+F

A floating tool bar will be displayed. Type  the search word in it .The tools
bar  provides the button to find the every occurrences of the given word.

b) Finding and Replacing of the Text
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This option is used to find a word and replace it with a new one. 
It is done by any of the following methods

1.command sequence : Edt> Find & Replace

2. Short cut keys          : Ctrl+H

3.Tool bar                     : Find&Replace button in the standard tool bar

A dialog box to enter the  search text and replace text will be appeared. The
check boxes match case and whole words only are provided.

Usually  the case of   text  is  not considered while searching.  Match case
allows to ensure  case sensitivity of the text.

Whole  word  only  helps  to  find the  text  that  appears  as  a  whole  word.
Replace all button helps to replace every matching words at a time.

X) Formatting the Documents.

General arrangement of the text is called formatting.

Three types of formatting:
1.Character formatting 2.Paragraph formatting and 3.Page formatting.

1.character formatting
It  is   the controlling of  the appearance of  each characters  in  the document.It
includes:

           a)setting font characteristics (size,type and color of the text)
b) text attributes(bold,italic ,underline etc)
c) text positions(superscript,subscript etc)

Any one of the  given methods can be used:

1. command sequence:Format>Character
2.Select  the text  ,place the mouse pointer in  the selected area,click  the right
button and choose character from the pull down menu.
The character dialog box will be displayed with the following tabs.
          a..Font : It provides font faces,style and size.

b.Font Effects:  It is used to set the Font Color,Effects and Relief. It  also
provides underlining,over lining and strike through effects.
     c.Position; Using this tab we can super script/subscript the text ,rotate the
text and  set   spacing between characters 

Hyperlink,Background(highlight)  and  Borders  are  the  other  tabs  in  the
character dialog box.

Some formatting features can be applied with the help of the short cut keys:

Ctrl+B -To make font style bold.
Crrl+U- To underline the text.
Ctrl+I – To make the text italic.
Ctrl+B+U+I – To give all of the above styles to the text.
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Copying a Format

Writer gives an easy way to copy the format of a text and apply to other
text of the document using Format paint brush button in the standard tool bar.
The procedure is as follows:
1.Select the text from where the format is copied
2.click on Format Paint Brush button.(double click to apply the same format to
multiple text.)
3.click on the  text where the format is to be applied.

2.Paragraph formatting
  It is the process of controlling appearance of the entire text in a paragraph.

Paragraph is a text delimited by the Enter key.
These facility can be used with any one of the following method.
1. Command sequence:Format>Paragraph
2.Select the text ,place the mouse pointer on the selected area,click the right
button and choose Paragraph from the pull down menu.

Paragraph formatting includes :

a) Paragraph alignment

It  refers  to  the  alignment  of  the  text  within  a  paragraph with  respect  to  the
document margin.
There are two categories of alignment s: Horizontal and vertical

 Horizontal alignment

Alignment of the text with respect to left and right margins.

a) Align Left: Align the selected text/paragraph to the left margin.
b) Align Right: Align the selected text/paragraph to the right margin.
a) Centered:Align the selected text/paragraph to the middle of the margin.
a) justified: The spaces between the words in a line are  adjusted in such a way
that the first word aligns with the left margin and the last word aligns with right
margin.

         Vertical alignment :

Alignment of text with  to8p and bottom margins of a cell in a table.This alignment
has no effect on normal text appearing in the document.

a) Top: The text is aligned to the top of the cell
a) Bottom: The text is aligned to the bottom of the cell
a) MIddle: The text is aligned to the middle of upper and lower margin of the cell

 b).Paragraph Indentation and Line Spacing:
            indentationThe indent  refers  to  the  distance  between the  text
boundaries and     the page margin.

Classification based on the nature indentation:

1.Left indent(Indent before text): Indentation between the left margin and the text
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2.Right indent(Indent after text): Indentation between the right margin and the
text
3.First line  indent: Indentation between the left margin and the first line of the
text.
4.Hanging  indent : Indentation between the left margin and all lines except the

first line of the text .

Classification based on the values given to the  indentation:

1.Postive indent: Here text is placed little inward from the margin.
2.Negative indent: Here text is placed little outward from the margin.

Line Spacing
It refers to the  space between the two lines of the document. It is also known as

the total height of the line of a text. 

c. Drop Caps Features
This feature is used to increase the height of the first letter of a paragraph

to the height of 2 or more lines.
To use this feature proceed as follows:
1.Place the cursor where we utilize the facility.
2.Open the Paragraph dialog box and select Drop Caps tab.
3. Specify the number of characters and number of lines to be dropped.
4. Click OK button.

d. Bullets and Numbering
 It is used to arrange the different items in a list.
Two types of lists 

a) Bulleted lists
 It is used when the items of the list does not require any order.
b) Numbered lists

 It is to used to present items in a particular order.

The procedure:
1.Click on format menu and choose Bullets and Numbering option.
Bullets and numbering window will be appeared
2.Select the desired bullet /number and click  OK button.
3. Go on with typing of each item.

A tool  bar appears at  the bottom of the IDE window helps to move the

items upwards and downwards.

3. Page Formatting

It is the setting of page layout and design.

Procedure:
1. Use the command sequence :Format>Page

2.The Page Style dialog box will be displayed. Using the different tabs  we can

apply  the different features to  a page.

Page Size (Paper Size) and Orientation

Kunhabdulla PT. GGHSS Thalassery ,Phone :98 0 98 52 1 52                Page 9



Orientation refers to whether the text is to be printed length wise(portrait)
or width wise (land scape).

We can set the orientation and paper size using the Page tab of the  Page
Style dialogue box.

Margins of the page can be set using ruler bars or Page Style dialogue box.

 Header and footer

         The common text appears on the top of every pages is called the header
and at the bottom is called the footer. A header is printed in the top margin while
the footer is printed in bottom margin.

 To insert the header
use the command sequence  Insert>Header.

To insert the  footer
use the command sequence Insert>Footer.

To insert page number in footer section 

 Place the cursor is in the footer section and use the command sequence
insert> field>Page Number

 Header/footer can be inserted with the help of Page Style dialogue box
also.

XI) Printing the document
We can take the hard copy of the document using any one of the following

procedure:

1.command sequence: File > Print
2 .short cut keys :Ctrl+P
3. Tools :Print button from the standard tool bar

The Print dialogue box will be opened .We can give page numbers, number
of copies etc.

Print Preview

It can be obtained  through any one of the given procedure:

1.Command sequence  File>Print Preview

2. shortcut : Ctrl+Shift+O

3.Tool bar: Print Preview option from the standard tool bar
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